• Welcome to the Best Streaming Community! You need login/register in-order to access forum without restriction.

Can't login to my premium account on TiviMate Premium

thro

New member
Offline
Hi, My IPTV box (android) broke down, I bought a new box (android).
Downloaded Tivimate and tried to log into my account with my email address and password for my premiumaccount, the app says it's the wrong password or email address, but it's the information I used in the previous box.
Tried to reset the password but no reset link was sent to me.
Downloaded the TiviMate Companion, it was able to reset the password but when I use my email address and the new password in the app it says that I have to pay for a subscription per year or a one time payment.
When I choose one time payment I get a reply that I have paid and that I did in February this year.
I use the same email address that I have for google play.
What am I doing wrong?
 

༺Crystal༻

Husham’s Helper
Staff member
Offline
Hi, My IPTV box (android) broke down, I bought a new box (android).
Downloaded Tivimate and tried to log into my account with my email address and password for my premiumaccount, the app says it's the wrong password or email address, but it's the information I used in the previous box.
Tried to reset the password but no reset link was sent to me.
Downloaded the TiviMate Companion, it was able to reset the password but when I use my email address and the new password in the app it says that I have to pay for a subscription per year or a one time payment.
When I choose one time payment I get a reply that I have paid and that I did in February this year.
I use the same email address that I have for google play.
What am I doing wrong?
You’re not doing anything wrong! 1st off..make sure if you are using a VPN..it is turned off when activating premium. Then try this:
Device settings > Apps > TiviMate > Force stop >Clear cache > RESTART device..then try again.

If that doesn’t help..Uninstall/Reinstall TiviMate. Make sure you are using the official current version from the Play Store.
 

thro

New member
Offline
You’re not doing anything wrong! 1st off..make sure if you are using a VPN..it is turned off when activating premium. Then try this:
Device settings > Apps > TiviMate > Force stop >Clear cache > RESTART device..then try again.

If that doesn’t help..Uninstall/Reinstall TiviMate. Make sure you are using the official current version from the Play Store.
Thanks for the help, but unfortunately none of the advice helped. Can't log into the TiviMate app on the box, it still says I've purchased one time. In the Tivimate app In the TiviMate Companion app, however, I can choose to buy a one-time cost, this is the same username and password in both apps.
Confused right now!
 

༺Crystal༻

Husham’s Helper
Staff member
Offline
Thanks for the help, but unfortunately none of the advice helped. Can't log into the TiviMate app on the box, it still says I've purchased one time. In the Tivimate app In the TiviMate Companion app, however, I can choose to buy a one-time cost, this is the same username and password in both apps.
Confused right now!
Ok. Go to the Google Play Store on your new device. Tap your account icon. In the menu..click Settings. Look in the Play Store version section. If there's an update available, tap Update Play Store. Your Play Store may not be up to date with the current version.
While you are in the Play Store Settings..make sure it is showing your subscription to TiviMate in the Payment/Subscriptions tab.
On your Android box..have you tried both passwords (your original and your recently changed) passwords for TiviMate?
 

thro

New member
Offline
Ok. Go to the Google Play Store on your new device. Tap your account icon. In the menu..click Settings. Look in the Play Store version section. If there's an update available, tap Update Play Store. Your Play Store may not be up to date with the current version.
While you are in the Play Store Settings..make sure it is showing your subscription to TiviMate in the Payment/Subscriptions tab.
On your Android box..have you tried both passwords (your original and your recently changed) passwords for TiviMate?
Thanks for all the help Crystal Blue,
When I got stuck after trying all your advice, I sent my problem to the developer, got a reply that there was an error/typo in my data.
Now everything works as it did in my previous box.
Thanks again for all the help!
Now I am happy again.
 

gilly76

New member
Offline
Thanks for all the help Crystal Blue,
When I got stuck after trying all your advice, I sent my problem to the developer, got a reply that there was an error/typo in my data.
Now everything works as it did in my previous box.
Thanks again for all the help!
Now I am happy again.
Good morning i have been having the same issues with tivimate, unable to login, do you have the developer information handy. because i have tried numerous times over the last 2 days with no luck. thanks
 

༺Crystal༻

Husham’s Helper
Staff member
Offline
Thanks for all the help Crystal Blue,
When I got stuck after trying all your advice, I sent my problem to the developer, got a reply that there was an error/typo in my data.
Now everything works as it did in my previous box.
Thanks again for all the help!
Now I am happy again.
That was going to be my next suggestion. Glad you got it all sorted! 😉
 

pete

Member
Offline
crystal i am having same issue but the gentleman did not help me out can you give me information regarding the fix
 

༺Crystal༻

Husham’s Helper
Staff member
Offline
crystal i am having same issue but the gentleman did not help me out can you give me information regarding the fix
Are you having login issues too? And are you saying the developer couldn’t help you?
 

pete

Member
Offline
I have always talked with crystal blue sorry to bother you
 

༺Crystal༻

Husham’s Helper
Staff member
Offline
I have always talked with crystal blue sorry to bother you
That’s me! 😂 I just shortened my username.
 
Top Bottom